[Solved] Chrome - Netflix not working | WidevineCDM not updating


Run the Chrome application as Administrator- This might solve the issue, If it doesn't follow the steps given below.

Fix that worked for me was to delete WidevineCDM from my Chrome folder, which allowed me to update Widevine under Chrome://components, and then go to Chrome://plugins and ensure that Widevine was enabled.

To delete WidevineCDM follow these steps. It may seem complicated but it's actually really easy and you can do it :D

If using Chrome and Windows 8.1:

Step 1:

Close the Chrome browser then press Windows Key + R to bring up the "Run" menu.
Type %userprofile%/appdata

Step 2:

When the window opens, click Local, then click Google, then click Chrome. Find the WidevineCDM folder and delete it.

Step 3:

Press Ctrl+Alt+Del and open the Task Manager.
Right click on anything that says chrome.exe and choose end task. There may not be anything to click on, that's fine. If running Windows 8.1 you can click 'Name' near the top to sort everything by name to make it easier to find. Close Task Manager.

Step 4:

Open Chrome. Go to chrome://components 
You should see Widevine at the top, click update. It should now update to the current version. Once it's finished (it only takes a moment)...

Step 5:

Go to chrome://plugins
Make sure that Widevine is enabled.

Step 6:

Launch Netflix again. Try to play a video. It should work now. If not, then there is something else going on and I apologize if I've wasted your time.



Share this:

Hey there! I'm Senthil Kumar Murugesan, An Infrastructure engineer with a focus on Cisco Unified Communications and Hacking. Also I’m happy to mention that I’m a Linux junkie, a Cisco proponent, a Tools fanatic and Script lover. This is a blog, a rambling of thoughts, and a result of technical experiments

48 comments

  1. Worked!! thanks a million

    ReplyDelete
    Replies
    1. please help me!!!! When i presed update on the widevine comoponent it said component not updated!!!!!!! Please please please i feel like i made a mistake deleting widevine :(

      Delete
    2. step 8 : do step 5 first

      Delete
    3. I have the same problem! have done all steps but it keeps saying component not updated =(

      Delete
  2. You're Awesome. That was quick, easy, and it worked. Thanks!

    ReplyDelete
  3. Worked like a charm, all other solutions were of no help (run as admin, remove/reinstall chrome etc). Thanks !

    ReplyDelete
  4. Worked!!! Thank you!

    ReplyDelete
  5. Another thanks, this worked for me.

    ReplyDelete
  6. You are my new favourite person on this planet, thank you my man!

    ReplyDelete
  7. How do I get widevinecdm back in appdata? This is not working for me I am using Windows 7.

    ReplyDelete
  8. On the components page whenever I click check for update it says component not updated every time I've tried many different online solution s but none have worked help?

    ReplyDelete
    Replies
    1. See if you emptied the recycle the bin after you deleted the widevine folder.
      It works for me after I deleted the widevine folder permanentely.

      Delete
  9. WOW! thank you so much!!
    I could find no solution on Netflix, nor Google. Looks who is smarter than all of them...YOU!!!!

    ReplyDelete
  10. Awesome! Thank you, this worked perfectly!

    ReplyDelete
  11. IT WORKS ! YOU SIR ARE A LEGEND !

    ReplyDelete
  12. please help, it didnt work!

    ReplyDelete
  13. After like days of giving up, this made my day lol.
    Tyyysm <3

    ReplyDelete
  14. This worked for me, thanks very much!!!

    ReplyDelete
  15. Worked like a charm. Many thanks!

    ReplyDelete
  16. It didn't work :( after I was almost done, when I opened the chrome://components and hit "update" it changed to "Checking for status" but it stayed like tha :(

    ReplyDelete
  17. A solution that actually worked. Well-explained, too. Appreciate it.

    ReplyDelete
  18. well damn. its legit m8s.

    ReplyDelete
  19. I just encountered this problem today. Initial google searches detailed long, tedious deleting and reinstalling across many hours. Your solution cut this short completely, and under 5 minutes, I'm happily watching Parks and Rec again. Thank you so much for your help. This was an excellent solution.

    tldr Legit solution, quick fix, great help. Much appreciate.

    ReplyDelete
  20. When I pressed the update button on widevine it still said component not updated. I don't know what to do and Widevine is enabled. Can someone please help me

    ReplyDelete
  21. This was easy-peasey and worked like a charm (fyi, I'm on Windows 10). Thank you!!!

    ReplyDelete
  22. Thank You, it worked

    ReplyDelete
  23. still didn't work,there's no such a WidevineCdm plus in like you said step5, and not up date when I click the update button

    ReplyDelete
  24. OMG¡¡¡ Thnx bro regards from México

    ReplyDelete
  25. Didn't work. Widevine plugin doesn't even show up on my components nor on my plugins, although there was a folder with it in the chrome installation folder.

    ReplyDelete
  26. When was the last time you actually looked at this? First - Widevine is nowhere near the top. On my machine it's #8 of 9. Second - There is no "Update" button, only one that says "Check for update". Third - If you hit that button, be prepared to wait. Mine's been running for over 30 minutes and still says "Checking for status...". Fourth - Even when it does finish (5 out of the 9 have finished) - EVERY SINGLE ONE says "Component not updated". So it doesn't actually perform the update, it simply checks to see if it's updated, and then informs you that it's not. There's still no way to actually get it to update. Useless.

    ReplyDelete
  27. on an late 08 mac - says not updated, when I do search for widevine, doesn't even show up. help please

    ReplyDelete
  28. Thank you, your detailed instructions solved my problem in a timely and efficient matter :)

    ReplyDelete
  29. This is what works for me. I did a bunch of steps which I'm not sure needed but in the end everything works fine and Widevine was found in chrome://component again.

    I followed up until Step 3 on this page. Upon finding out there are Widevine component in the ChromeDefaultData I deleted that folder as well. Next I go to empty my Recycle bin. Then I go to uninstall Chrome and then restart my computer once it's finished uninstalling. Finally I opened Internet Explorer, downloaded Chrome and reinstalled it again. After that I opened "chrome://component" and was able to find Widevine again. I then processed to click on update and it updated with no issue.

    P/s: I should add that before all of the above steps I downloaded and installed the latest version of Microsoft Silverlight

    Hope this works for everyone!

    ReplyDelete
    Replies
    1. same to me but so fuckin slowwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwww

      Delete
  30. I am not used to things like this working for me, but this totally worked. Thanks so much!

    ReplyDelete
  31. Another satisfied customer. Many thanks, Senthil.

    ReplyDelete
  32. It wouldn't work until I emptied my recycle bin. Then all was well. Thank you.

    ReplyDelete
  33. Thank you!! Worked for me :)

    ReplyDelete
  34. MAKE SURE POP UP BLOCKER IS TURNED OFF!!! I worked for an hour on this, following nearly every suggestion except to delete the folder. Finally, I decided to check and see if my pop-up blocker was the problem. Not only did the component for Netflix update, so did all the other components that were in need of updating!!!

    ReplyDelete
  35. MAKE SURE POP UP BLOCKER IS TURNED OFF!!! I worked for an hour on this, following nearly every suggestion except to delete the folder. Finally, I decided to check and see if my pop-up blocker was the problem. Not only did the component for Netflix update, so did all the other components that were in need of updating!!!

    ReplyDelete

Google Analytics Alternative