[Fix] GNS3 IOU Error - Error while creating project: Client version 1.3.13 differs with server version 1.3.3



This post will help you to understand why we receive the below error and how to solve it. Even if you get different numbers, this solution will work.

=> Error while creating project: Client version 1.3.13 differs with server version 1.3.3

The IOU VM version number must match with the version number of the GNS3 software. If your IOU VM is running a different version of gns3 than your client, you will get that error message and will have to fix it. You have 2 solutions, One is to degrade your GNS3 to your IOU version. Other one is to upgrade your IOU version to match the GNS3 version.

Solution 1:  Identify the version of your IOU. For example, if it is 1.3.3, you will have to download the same (1.3.3) version of GNS3 as well.

If you want to download a specific version of GNS3, please visit https://github.com/GNS3/gns3-gui/releases.

Solution 2: If you prefer to use a newer version of GNS3, you can upgrade your old IOU VM to the newer version.

This is normal that whenever you upgrade your gns3 you also have to update it on the IOU VM. Its easy, with the IOU VM powered off,  edit its network settings to attach to "NAT" - so it can go out on the internet to update. start the VM, log on as root, pasword cisco and enter the following command:

pip3 install gns3-server==1.3.13

1.3.13 is the version of GNS3 (Use the version that you need), so I want to upgrade my IOU to the same version. Once you run the command, it should download and install the update. all sorts of warnings will flash by the screen but that doesn't matter as long as the last line says something like: "Install of gns3 was sucessful" now to shutdown your vm - use the command

shutdown -h now

once shutdown,  edit its network settings to attach to "Host-only Adapter", fire it up and you should be able to connect to it and use run IOU images (as long as you remembered to upload them to the new IOU VM.

I hope this helps, Let me know your comments.

Share this:

Hey there! I'm Senthil Kumar Murugesan, An Infrastructure engineer with a focus on Cisco Unified Communications and Hacking. Also I’m happy to mention that I’m a Linux junkie, a Cisco proponent, a Tools fanatic and Script lover. This is a blog, a rambling of thoughts, and a result of technical experiments

4 comments

  1. Great post! I am actually getting ready to across this information, It's very helpful for this blog.Also great with all of the valuable information you have Keep up the good work you are doing well.

    digital marketing company in chennai
    seo company in chennai

    ReplyDelete
  2. Hi Mr.senthil
    Issue of server ip mismatch with client resolved..one more thing is that multilayer switches not accepting command of..... Int vlan1... to assign IP to switch...it show error of invalid command..please suggest ASAP

    ReplyDelete
  3. I cant wait to check out some of these blogs! I’ve really wanted to start learning more about cars and auto repairs lately and I think this will help a lot. I think it can save my family some money if we knew how to do some repairs at home.! Thanks again for all the options.

    car wash services in mumbai

    ReplyDelete
  4. I got the same error => Error while creating project: Client version 1.5.2 differs with server version 1.3.10, so i followed your steps but i did not see successful installation.
    I just got Running setup.py (PATH)egg_info for package gns3-server, Python 3.4 or higher is required, Complete output from command python setup.py egg_info: Python 3.4 or higher is required

    My GNS3 is latest version.
    Windows 10 64bit

    ReplyDelete

Google Analytics Alternative